Somma delle ore e dei minuti

Ultima modifica: 21-06-2016

 

Vediamo ora di risolvere alcuni problemi che riguardano la somma di ore e minuti.

I problemi che tratteremo saranno questi:

Partiamo come il solito da una tabella di esempio:

Un semplice orario di ingresso uscita:

A B C D E
1
2 data entrata uscita tot ore
3 lunedì 6.00 14.00 8.00
4 martedì 6.00 14.00 8.00
5 mercoledì 14.00 22.00 8.00
6 giovedì 14.00 22.00 8.00
7 venerdì 22.00 6.00 8.00
8 sabato 22.00 6.00 8.00
9 domenica 14.00 16.00 2.00
10 TOT ORE 50.00

In questa tabella dobbiamo affrontare 2 problemi importanti:

Per formattarele celle:

Gli orari di entrate ed uscite vanno inserite, dopo la formattazione delle celle, digitando le ore ed i minuti separati dal doppio punto ( : ).

nella colonna dei totali (la colonna E) vanno messe le formule:

=SE(D3>C3;D3-C3;1+D3-C3)
=SE(D4>C4;D4-C4;1+D4-C4)
ecc

In queste formule usiano la funzione SE per stabilire se l'orario che stiamo calcolando si trova a cavallo della mezzanotte.

se D3 > C3.... se è vero (non siamo a cavallo della mezzanotte: 14.00 < 22.00) basta la semplice operazione: D3-C3; se è falso (siamo a cavallo della mezzanotte: 22.00 > 6.00) al calcolo aggiungiamo un giorno: 1+D3-C3

Quando le formule si susseguono in celle contigue, per non aver la noia di ripeterle manualmente è possivile usare il trascinamente.
Per trascinare il contenuto di una cella e relative formattazioni si procede in questo modo

Si seleziona la cella

Quando il cursore prende la forma di un + si preme il tasto SN del mouse e si trascina nella direzione voluta

Quando si arriva nella posizione desiderata si rilascia il mouse e nelle celle così riempite si vedranno le formule ed eventuali formattazioni della cella trascinata.

 

Nell'ultima cella, formattata anch'essa con [h].mm si inserirà la semplice somma

=SOMMA(E3:E9)

 

Un orario spezzato da una probabile pausa pranzo

Nella stessa giornata abbiamo due ingressi ed uscite.

In questa tabella gli orari sono abbastanza regolari e sono tutti entro la giornata

A B C D E F G
               
1 Nome Data Ora Ingresso Ora uscita Ora ingresso ora uscita totale
2 mic 02/02/2007 8.01 12.24 15.00 20.21 9.44
3 mac 03/02/2007 7.59 12.01 15.59 20.01 8.04
4 giov 04/02/2007 6.55 12.40 15.50 20.10 10.05
5 ant 05/02/2007 6.12 12.40 15.50 20.10 10.48
6 pasq 06/02/2007 6.07 12.40 15.50 20.10 10.53
7 gaet 07/02/2007 6.59 12.41 15.50 20.15 10.07
8 gab 08/02/2007 6.45 12.40 15.50 20.10 10.15
9 gios 09/02/2007 6.48 12.40 15.50 20.10 10.12
10 marc 10/02/2007 6.55 12.40 15.50 20.09 10.04
11 Totale ore         90.12

 

Nella tabella sottostante ho, volutamente, mettere degli orari, immagino, impossibili che si trovano a cavallo della mezzanotte

A B C D E F G
               
1 Nome Data Ora Ingresso Ora uscita Ora ingresso ora uscita totale
2 mic 02/02/2007 8.01 12.24 15.00 20.21 9.44
3 mac 03/02/2007 7.59 12.01 15.59 20.01 8.04
4 giov 04/02/2007 6.55 12.40 15.50 20.10 10.05
5 ant 05/02/2007 6.12 12.40 15.50 20.10 10.48
6 pasq 06/02/2007 6.07 12.40 15.50 20.10 10.53
7 gaet 07/02/2007 6.59 12.41 15.50 20.15 10.07
8 gab 08/02/2007 6.45 12.40 15.50 20.10 10.15
9 gios 09/02/2007 6.48 12.40 23.15 3.55 10.32
10 marc 10/02/2007 22.00 5.00 15.50 20.09 11.19
11 Totale ore 91.47

 

Entrambe le tabelle sono trattate con le stesse formule.

Ma andiamo in ordine anche con queste 2 tabelle che sembrano più complesse della prima, ma in realtà non lo sono.

anche per questa tabella usiamo le stesse formattazioni usate per la prima tabella:

=(D3-C3+(D3<C3))+(F3-E3)+(F3<E3)
=(D4-C4+(D4<C4))+(F4-E4)+(F4<E4)
ecc

Queste formule sono perfettamente compatibili con quelle usate con la prima tabella che dovrebbero essere così trasformate:

=SE(D3>C3;D3-C3;1+D3-C3) + SE(F3>E3;F3-E3;1+F3-E3)

ma hanno il vantaggio di essere più concise.

con questa formula:

D3-C3+(D3<C3)

al semplice calcolo D3-C3 aggiungiamo il valore di un confronto booleano D3<C3 che può essere '1' se il confronto è vero, '0' se è falso. Questo fatto consente alla formula di svolgere lo stesso compito dell'altra in caso di dover operare su orari che sono a cavallo della mezzanotte.

 

Calcolo compenso per ore lavorative

Se la nostra tabella è formattata in maniera ordinata l'operazione è semplice.

Le celle coi totali delle ore formattate con Formato cella => Numero => Personalizzato => h.mm oppure Formato cella => Numero => Personalizzato => [h].mm e le celle del compenso orario con Formato cella => Valuta.

Questo è il calcolo da eseguire:

=E2*F2*24

E2 è la cella che contiene il totale delle ore

F2 è la cella che contiene il compenso orario

24 sono le ore di un giorno

Questo perchè, se analizziamo il problema, le ore, come le date, per excel sono semplici numeri seriali che rappresentano:

Per questo motivo, lavorando su orari, dobbiamo essere consapevoli che in realtà stiamo lavorando su frazioni di un giorno per cui volendo calcolare il costo di una prestazione oraria è necessario eseguire anche il prodotto per 24 che sono le ore in un giorno.